const regex = /^[A-Z](?:[a-z0-9@()\[\]{}._\-!#$%&'*+\/=?^`|~]|\s[A-Z0-9@()\[\]{}._\-!#$%&'*+\/=?^`|~])*$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z](?:[a-z0-9@()\\[\\]{}._\\-!#$%&\'*+\\\/=?^`|~]|\\s[A-Z0-9@()\\[\\]{}._\\-!#$%&\'*+\\\/=?^`|~])*$', 'mg')
const str = `D#-' -.1424124123
a
A 9jasvc
Adas s
A12334-# AdadA`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}