#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!:(?=string:))string"
Local $sString = "string - gets deleted" & @CRLF & _
"blah string - gets deleted" & @CRLF & _
":string blah - gets deleted" & @CRLF & _
":string: string - gets deleted" & @CRLF & _
"thing :string: - doesn't get deleted"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")