using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!:(?=string:))string";
string input = @"string - gets deleted
blah string - gets deleted
:string blah - gets deleted
:string: string - gets deleted
thing :string: - doesn't get deleted";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}