re = /(?<!:(?=string:))string/m
str = 'string - gets deleted
blah string - gets deleted
:string blah - gets deleted
:string: string - gets deleted
thing :string: - doesn\'t get deleted'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end