const regex = /(?:\G|^)[^\p{L}0]*\K0/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G|^)[^\\p{L}0]*\\K0', 'gm')
const str = `00000000AAAAAAAAAA0AAAAAAAAAA0AAAAAAAAAAAAAAAAAAAAAAAAD0
102030405000AZD`;
const subst = `.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);