use strict;
my $str = '00000000AAAAAAAAAA0AAAAAAAAAA0AAAAAAAAAAAAAAAAAAAAAAAAD0
102030405000AZD';
my $regex = qr/(?:\G|^)[^\p{L}0]*\K0/mp;
my $subst = '.';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";