$re = '/(?:\G|^)[^\p{L}0]*\K0/m';
$str = '00000000AAAAAAAAAA0AAAAAAAAAA0AAAAAAAAAAAAAAAAAAAAAAAAD0
102030405000AZD';
$subst = ".";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;