import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?mx)\n"
+ "^\n"
+ "(?P<item_code>\\d\\d\\.\\d\\d\\.\\d{4})\n"
+ "\\s+\n"
+ "(?P<quantity>\\d+)\n"
+ "\\s+\n"
+ "(?P<description>\\S[\\s\\S]*?)\n"
+ "[ ]+\n"
+ "(?P<unit_price>\\d+(?:,\\d\\d)?)\n"
+ "[ ]+\n"
+ "(?P<total_sum>\\d+(?:,\\d\\d)?)\n"
+ "$";
final String string = "05.04.0090\n"
+ "1\n\n\n"
+ "erhältlichen Tableau Interfaces\n"
+ "lassen sich zusätzliche GLT-Kontakte\n"
+ "aufschalten. Das System kann\n\n"
+ "die zwei Szenarien-Modi \"Urlaub\" und\n"
+ "Abwesenheit\" verwalten. Für beide\n"
+ "Modi können bestimmte Parameter\n"
+ "programmiert werden.\n\n"
+ "Das WAREMA climatronic Bediengerät\n"
+ "kann preisgleich auch\n\n"
+ "in den Farben \"schwarz\" oder\n"
+ "\"schwarz/silber\" geliefert werden.\n"
+ "Liefern und montieren. 882,75 882,75\n\n\n"
+ "05.04.0091\n"
+ "5\n"
+ "foo bar. 170,42 17042";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}