const regex = new RegExp('(?mx)
^
(?P<item_code>\\d\\d\\.\\d\\d\\.\\d{4})
\\s+
(?P<quantity>\\d+)
\\s+
(?P<description>\\S[\\s\\S]*?)
[ ]+
(?P<unit_price>\\d+(?:,\\d\\d)?)
[ ]+
(?P<total_sum>\\d+(?:,\\d\\d)?)
$', 'g')
const str = `05.04.0090
1
erhältlichen Tableau Interfaces
lassen sich zusätzliche GLT-Kontakte
aufschalten. Das System kann
die zwei Szenarien-Modi "Urlaub" und
Abwesenheit" verwalten. Für beide
Modi können bestimmte Parameter
programmiert werden.
Das WAREMA climatronic Bediengerät
kann preisgleich auch
in den Farben "schwarz" oder
"schwarz/silber" geliefert werden.
Liefern und montieren. 882,75 882,75
05.04.0091
5
foo bar. 170,42 17042`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}