# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"(?mx)\n"
r"^\n"
r"(?P<item_code>\d\d\.\d\d\.\d{4})\n"
r"\s+\n"
r"(?P<quantity>\d+)\n"
r"\s+\n"
r"(?P<description>\S[\s\S]*?)\n"
r"[ ]+\n"
r"(?P<unit_price>\d+(?:,\d\d)?)\n"
r"[ ]+\n"
r"(?P<total_sum>\d+(?:,\d\d)?)\n"
r"$")
test_str = ("05.04.0090\n"
"1\n\n\n"
"erhältlichen Tableau Interfaces\n"
"lassen sich zusätzliche GLT-Kontakte\n"
"aufschalten. Das System kann\n\n"
"die zwei Szenarien-Modi \"Urlaub\" und\n"
"Abwesenheit\" verwalten. Für beide\n"
"Modi können bestimmte Parameter\n"
"programmiert werden.\n\n"
"Das WAREMA climatronic Bediengerät\n"
"kann preisgleich auch\n\n"
"in den Farben \"schwarz\" oder\n"
"\"schwarz/silber\" geliefert werden.\n"
"Liefern und montieren. 882,75 882,75\n\n\n"
"05.04.0091\n"
"5\n"
"foo bar. 170,42 17042")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.