using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:-{1}\d+x{1}\d+)\.(?:jp(?:e?g|e|2)|gif|png|tiff?|bmp|ico|heic|heif|webp|jxr|wdp|dng|cr2|arw)$";
string input = @"4457-Some-ridiculous-picture-600x450.jpg
4457-Some-ridiculous-picture-768x576.jpg
4457-Some-ridiculous-picture.jpg
4557-an-object-measuring-25-x-20-x-5mm-300x225.jpg
4557-an-object-measuring-25-x-20-x-5mm.jpg
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}