// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:-{1}\d+x{1}\d+)\.(?:jp(?:e?g|e|2)|gif|png|tiff?|bmp|ico|heic|heif|webp|jxr|wdp|dng|cr2|arw)$").unwrap();
let string = "4457-Some-ridiculous-picture-600x450.jpg
4457-Some-ridiculous-picture-768x576.jpg
4457-Some-ridiculous-picture.jpg
4557-an-object-measuring-25-x-20-x-5mm-300x225.jpg
4557-an-object-measuring-25-x-20-x-5mm.jpg
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}