import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:-{1}\\d+x{1}\\d+)\\.(?:jp(?:e?g|e|2)|gif|png|tiff?|bmp|ico|heic|heif|webp|jxr|wdp|dng|cr2|arw)$";
final String string = "4457-Some-ridiculous-picture-600x450.jpg\n"
+ "4457-Some-ridiculous-picture-768x576.jpg\n"
+ "4457-Some-ridiculous-picture.jpg\n"
+ "4557-an-object-measuring-25-x-20-x-5mm-300x225.jpg\n"
+ "4557-an-object-measuring-25-x-20-x-5mm.jpg\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}