#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mU)<Notes>(?:(?!<Notes>)[\s\S])*?sample(?:[\s\S\w]+)<\/Notes>(?:(?<![\s\S\w]<\/Notes>))*?"
Local $sString = "TextBefore<Notes>this is sample notes</Notes>TextWiths1ample<Notes>this is sample notes</Notes>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")