re = /<Notes>(?:(?!<Notes>)[\s\S])*?sample(?:[\s\S\w]+)<\/Notes>(?:(?<![\s\S\w]<\/Notes>))*?/m
str = 'TextBefore<Notes>this is sample notes</Notes>TextWiths1ample<Notes>this is sample notes</Notes>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end