import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=id:\\s*'[^']*?)\\s(?=[^']*')";
final String string = "var user1 = {id: 'Alan Banks'};\n"
+ "var user2 = {id: 'Chris Daily'};\n"
+ "var user1 = {id: 'Alan Banks TEXT here'};\n"
+ "var user2 = {id: 'Chris Daily More text'};";
final String subst = "_";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}