use strict;
my $str = 'var user1 = {id: \'Alan Banks\'};
var user2 = {id: \'Chris Daily\'};
var user1 = {id: \'Alan Banks TEXT here\'};
var user2 = {id: \'Chris Daily More text\'};';
my $regex = qr/(?<=id:\s*'[^']*?)\s(?=[^']*')/mp;
my $subst = '_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";