re = /(?<=id:\s*'[^']*?)\s(?=[^']*')/m
str = 'var user1 = {id: \'Alan Banks\'};
var user2 = {id: \'Chris Daily\'};
var user1 = {id: \'Alan Banks TEXT here\'};
var user2 = {id: \'Chris Daily More text\'};'
subst = '_'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result