import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\s\\*]+)@param";
final String string = "/**\n"
+ " * The addVertex method checks to see if the vertex isn't null, and then if\n"
+ " * the graph does not contain the vertex, the vertex is then added and true\n"
+ " * is returned\n"
+ " *\n"
+ " * @param vertex\n"
+ " *\n"
+ " * @throws NullPointerException.\n"
+ " *\n"
+ " * @return b\n"
+ " */";
final String subst = ".$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}