const regex = /([\s\*]+)@param/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\s\\*]+)@param', 'gm')
const str = `/**
* The addVertex method checks to see if the vertex isn't null, and then if
* the graph does not contain the vertex, the vertex is then added and true
* is returned
*
* @param vertex
*
* @throws NullPointerException.
*
* @return b
*/`;
const subst = `.$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);