import re
regex = re.compile(r"([\s\*]+)@param", flags=re.MULTILINE)
test_str = ("/**\n"
" * The addVertex method checks to see if the vertex isn't null, and then if\n"
" * the graph does not contain the vertex, the vertex is then added and true\n"
" * is returned\n"
" *\n"
" * @param vertex\n"
" *\n"
" * @throws NullPointerException.\n"
" *\n"
" * @return b\n"
" */")
subst = ".$1"
result = regex.sub(subst, test_str)
if result:
print(result)