#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:(//\w+\s+JOB(?: \w+)?)\h*|\G(?!^)),(\w+=\w+)"
Local $sString = "//ADBB503 JOB ,MSGCLASS=2,CLASS=P" & @CRLF & _
"//ABCD JOB Something,MSG=NTNG,CLASS=ABC"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)