use strict;
my $str = '//ADBB503 JOB ,MSGCLASS=2,CLASS=P
//ABCD JOB Something,MSG=NTNG,CLASS=ABC';
my $regex = qr~(?:(//\w+\s+JOB(?: \w+)?)\h*|\G(?!^)),(\w+=\w+)~mp;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";