re = /(?:(\/\/\w+\s+JOB(?: \w+)?)\h*|\G(?!^)),(\w+=\w+)/m
str = '//ADBB503 JOB ,MSGCLASS=2,CLASS=P
//ABCD JOB Something,MSG=NTNG,CLASS=ABC'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result