import re
regex = re.compile(r"\bR-?(?<Lower>\d{9})\b", flags=re.MULTILINE)
test_str = ("ABCD/SESSION REMARKS/SESSION REMARKS_002FT2213700215_ /CODTYPTR/049 //R101841246/058 Session 220517080 REF: 02024741031486605002FT221\n"
"\"R-101880298/GTB - GTB 981018802981 from GENERAL To GENERAL REF: 0000202582697981018802981 REF:205000000000760015362205171040\" and \"R101880298/GTB - GTB 981018802981 from GENERAL To GENERAL REF: 0000202582697981018802981 REF:205000000000760015362205171040")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")