import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Source:\\s*\\K.+\\b";
final String string = "Art 1 This is article one. Source: The Guardian.\n"
+ "Art 2 This is article two. Source: New York Times.\n"
+ "Art 3 This is article three. Source: The Washington Post.\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}