const regex = /Source:\s*\K.+\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Source:\\s*\\K.+\\b', 'gm')
const str = `Art 1 This is article one. Source: The Guardian.
Art 2 This is article two. Source: New York Times.
Art 3 This is article three. Source: The Washington Post.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}