re = /Source:\s*\K.+\b/m
str = 'Art 1 This is article one. Source: The Guardian.
Art 2 This is article two. Source: New York Times.
Art 3 This is article three. Source: The Washington Post.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end