$re = '/^\/test\/[^\/]+\/contact\/[^\/]+$/m';
$str = '/test/1234/contact/abcd
/test/abcd/1234/contact/abcd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);