re = /^\/test\/[^\/]+\/contact\/[^\/]+$/m
str = '/test/1234/contact/abcd
/test/abcd/1234/contact/abcd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end