$re = '/(?x) # Matches 10 characters or more, needs capitals & lowercase alphabetical characters, numbers and punctuation repersented
^(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[\!-\/\:-\@\[-\`\{-\~])(?:.{10,})$
# Could have used [[:punct:]] for puntuation but regex engine may not support
# https://geekalicious.blog for mOAR!/m';
$str = '# Won\'t Match
abc
1234567890
BcA@haha
# Will match
ABCabc123!
BcA@123lalalalalalala
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);