import Foundation
let pattern = ##"""
(?x) # Matches 10 characters or more, needs capitals & lowercase alphabetical characters, numbers and punctuation repersented
^(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[\!-\/\:-\@\[-\`\{-\~])(?:.{10,})$
# Could have used [[:punct:]] for puntuation but regex engine may not support
# https://geekalicious.blog for mOAR!
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
# Won't Match
abc
1234567890
BcA@haha
# Will match
ABCabc123!
BcA@123lalalalalalala
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)