// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?x) # Matches 10 characters or more, needs capitals & lowercase alphabetical characters, numbers and punctuation repersented
^(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[\!-\/\:-\@\[-\`\{-\~])(?:.{10,})$
# Could have used [[:punct:]] for puntuation but regex engine may not support
# https://geekalicious.blog for mOAR!").unwrap();
let string = "# Won't Match
abc
1234567890
BcA@haha
# Will match
ABCabc123!
BcA@123lalalalalalala
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}