#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\w{3} \d{2} \d{2}:\d{2}:\d{2}) ([a-z]+) ([\w\d\[\]]+): (.*)$"
Local $sString = "Jul 28 06:26:52 debian tripwire[29710]: Integrity Check Failed: File could not be opened." & @CRLF & _
"Jun 29 06:54:01 debian kernel: [586133.428279] device eth0 left promiscuous mode" & @CRLF & _
"Jul 29 09:29:07 debian kernel: [586139.564278] device eth0 entered promiscuous mode" & @CRLF & _
"Dec 14 17:30:45 debian Cacti[14619]: POLLER: WARNING: Cron is out of sync with the Poller Interval!" & @CRLF & _
"Jan 29 11:48:59 debian Cacti[14626]: CMDPHP: Host[1] DS[29] WARNING: Result from SNMP not valid." & @CRLF & _
"END of 00:00:00 logging - rotation in progress" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")