re = /^(\w{3} \d{2} \d{2}:\d{2}:\d{2}) ([a-z]+) ([\w\d\[\]]+): (.*)$/m
str = 'Jul 28 06:26:52 debian tripwire[29710]: Integrity Check Failed: File could not be opened.
Jun 29 06:54:01 debian kernel: [586133.428279] device eth0 left promiscuous mode
Jul 29 09:29:07 debian kernel: [586139.564278] device eth0 entered promiscuous mode
Dec 14 17:30:45 debian Cacti[14619]: POLLER: WARNING: Cron is out of sync with the Poller Interval!
Jan 29 11:48:59 debian Cacti[14626]: CMDPHP: Host[1] DS[29] WARNING: Result from SNMP not valid.
END of 00:00:00 logging - rotation in progress
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end