import Foundation
let pattern = #"^(\w{3} \d{2} \d{2}:\d{2}:\d{2}) ([a-z]+) ([\w\d\[\]]+): (.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Jul 28 06:26:52 debian tripwire[29710]: Integrity Check Failed: File could not be opened.
Jun 29 06:54:01 debian kernel: [586133.428279] device eth0 left promiscuous mode
Jul 29 09:29:07 debian kernel: [586139.564278] device eth0 entered promiscuous mode
Dec 14 17:30:45 debian Cacti[14619]: POLLER: WARNING: Cron is out of sync with the Poller Interval!
Jan 29 11:48:59 debian Cacti[14626]: CMDPHP: Host[1] DS[29] WARNING: Result from SNMP not valid.
END of 00:00:00 logging - rotation in progress
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)