import re
regex = re.compile(r"discord(?:app)?\.com\/(?:(friend-)?invite|servers)?\/([a-z0-9\-]+)|discord\.gg\/(?:\S+\/)?([a-z0-9\-]+)", flags=re.MULTILINE)
test_str = ("discord.com/invite/abc123\n"
"discordapp.com/invite/123abc\n"
"discord.gg/invite/abc123\n"
"discord.gg/123abc\n"
"discord.com/friend-invite/abc123\n"
"discord.com/servers/123abc\n"
"discordapp.com/servers/abc123")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")