package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[&?]((?:firstName|lastName|phone1|address|zipcode)=|email=(?:.*@.*\.)?)[^&]*`)
var str = `https://example.com/?&iframeLoad=true&firstName=David&lastName=Faber&email=xyzzy?@xyzzy.com&phone1=1234567890&address=myaddress&zipcode=myzip&isAvailableReferral=true&isAvailableDirect=false`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}