const regex = /[&?]((?:firstName|lastName|phone1|address|zipcode)=|email=(?:.*@.*\.)?)[^&]*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[&?]((?:firstName|lastName|phone1|address|zipcode)=|email=(?:.*@.*\\.)?)[^&]*', 'g')
const str = `https://example.com/?&iframeLoad=true&firstName=David&lastName=Faber&email=xyzzy?@xyzzy.com&phone1=1234567890&address=myaddress&zipcode=myzip&isAvailableReferral=true&isAvailableDirect=false`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}