package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^.*\[.*\].*\[client\s+.*:.*\].*authentication\s+failure.*\.php$`)
var str = `[Thu Jan 07 21:09:50.120651 2016] [:error] [pid 26210] [client 123.123.123.123:12878] user hgfhfg authentication failure, referer: https://example.com/administrator/index.php`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}