$re = '/^.*\[.*\].*\[client\s+.*:.*\].*authentication\s+failure.*\.php$/';
$str = '[Thu Jan 07 21:09:50.120651 2016] [:error] [pid 26210] [client 123.123.123.123:12878] user hgfhfg authentication failure, referer: https://example.com/administrator/index.php';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);