const regex = /^9?[\d]{8}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^9?[\\d]{8}$', 'gm')
const str = `# Primeiro tentaremos com 8 dígitos
12345678
92841742
83457854
# Agora vamos tentar com 9 dígitos.
# Apenas os que iniciam com o dígito 9 deverão ser válidos.
183457854
983457854
912345678
123456789`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}