re = /^9?[\d]{8}$/m
str = '# Primeiro tentaremos com 8 dígitos
12345678
92841742
83457854
# Agora vamos tentar com 9 dígitos.
# Apenas os que iniciam com o dígito 9 deverão ser válidos.
183457854
983457854
912345678
123456789'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end