// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^9?[\d]{8}$").unwrap();
let string = "# Primeiro tentaremos com 8 dígitos
12345678
92841742
83457854
# Agora vamos tentar com 9 dígitos.
# Apenas os que iniciam com o dígito 9 deverão ser válidos.
183457854
983457854
912345678
123456789";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}