using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<li>(?!<\/li>)([^\n]+)";
string input = @"<li>(?!""<\/li>"".*);
<li>([^\n]+)(?!<\/li>);
<li>(?!<\/li> )([^<\/li>\n]+)
<li>(?!<\/li>)([^\n]+)
<li>.*(?!<\/li>)
<li>KO </li>
<li>Ok";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}