import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<li>(?!<\\/li>)([^\\n]+)";
final String string = "<li>(?!\"<\\/li>\".*);\n"
+ "<li>([^\\n]+)(?!<\\/li>);\n"
+ "<li>(?!<\\/li> )([^<\\/li>\\n]+)\n"
+ "<li>(?!<\\/li>)([^\\n]+)\n"
+ "<li>.*(?!<\\/li>)\n\n\n"
+ "<li>KO </li>\n"
+ "<li>Ok";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}