package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<time>\d{1,2}-\d{1,2}-\d{4} +\d{1,2}:\d{1,2}:\d{1,2},\d{3}) +(?<message1>[A-Z]+) .*\[ID=(?<ID>\w+)] +\[N=(?<N>\w+)] (?<messages>.*)`)
var str = `[14-10-2016 00:00:04,004 INFO WebService:1603] [172.16.1.10] [0000077000013] [ID=N0000077000013] [N=147639237688] REQUEST getStatus`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}