import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<time>\\d{1,2}-\\d{1,2}-\\d{4} +\\d{1,2}:\\d{1,2}:\\d{1,2},\\d{3}) +(?<message1>[A-Z]+) .*\\[ID=(?<ID>\\w+)] +\\[N=(?<N>\\w+)] (?<messages>.*)";
final String string = "[14-10-2016 00:00:04,004 INFO WebService:1603] [172.16.1.10] [0000077000013] [ID=N0000077000013] [N=147639237688] REQUEST getStatus";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}