package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\{([^}]*):([^}]*)\}`)
var str = `I think {if:3|=|0|you are|TechRax is} {range:1|100}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}