$re = '/\{([^}]*):([^}]*)\}/';
$str = 'I think {if:3|=|0|you are|TechRax is} {range:1|100}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);